React Native ve NPM@5 Uyumsuzluğu

 

Merhaba dostlar, bugün beklenmedik bir hata hakkında konuşacağız. Son zamanlarda react native ile uğraşmaya başlamışsanız veya npm‘i güncelledikten sonra yeni bir projeye başladıysanız farketmişsinizdir, react native ve npm’in son sürümleri beraber çalışamıyor. Bu büyük bir hayal kırıklığı aslında ve github issue’su açılalı 6 ay olmasına rağmen hala sorun devam etmekte.

Peki uyumsuz diye react native ile uygulama geliştirmeyi bırakacak mıyız? gibi bir soru olabilir. Hayır, tabi.

İki yöntem ile bu konuyu göz ardı edebiliyoruz şuan için:

 

1) npm’i bir alt sürümüne düşürmek. Downgrade yani.

1
npm install -g npm@4

 

2) npm yerine yarn kullanmak. Yarn da JavaScript için bir package manager.

şu link ile yarn’ı windows makinanıza indirebilirsiniz. Diğer platformlar için yarn indirme yöntemlerini de şu sayfadan bulabilirsiniz.

Not: Github issue’sunu takip etmek isteyenler için linki de paylaşayım, bir çözüm bulunduğunda buradan öğrenebilirsiniz:

https://github.com/facebook/react-native/issues/14767

ahmet

Ahmet Kılınç - Software Developer

Bunlar da hoşunuza gidebilir...

1 Cevap

  1. 3 Ocak 2018

    […] ile npm’in son sürümleri arasındaki uyuşmazlık ve nasıl bir yol izlenebileceğine şu yazımda […]

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

This site uses Akismet to reduce spam. Learn how your comment data is processed.